PHP

Derzeit können Sie bei uns zwischen den PHP-Versionen 5.2, 5.3, 5.6 und 7.0 wählen. Wir können Ihre Site auf Anfrage gern in wenigen Sekunden auf eine andere Version umstellen.

Die installierte PHP-Version sowie die enthaltenen Module können Sie mit eine Seite mit phpinfo()-Funktion auslesen. In allen Setups unterstützen wir unter anderem die Module curl, GD, Ioncube Loader, MCrypt, Memcache, MySQL, Redis, XCache, Zend Optimizer sowie die wichtigsten PEAR-Bibliotheken.

In der Regel läuft PHP bei uns über einen FastCGI-Wrapper. Das bedeutet, daß der PHP-Interpreter nicht bei jedem Aufruf der Seite gestartet wird, sondern daß eine Anzahl von PHP-Prozessen vom Webserver gestartet wird, die dann auf Anfragen warten und diese sehr schnell verarbeiten

In allen Setups bei uns können Sie die Einstellungen der Datei php.ini selbst anpassen. Sie finden diese Datei im Ordner /etc in Ihrem Homeverzeichnis. Bitte beachten Sie, daß diese Datei immer nur beim Start eines FastCGI-Prozesses ausgelesen wird. Wenn Sie etwas ändern kann es deshalb bis zu eine Stunde dauern, bis die Änderung aktiv wird.

  • English
  • Dansk